JavaScript: Reverse a number

JavaScript Function: Exercise-1 with Solution

Write a JavaScript function that reverse a number.
Sample Data and output:
Example x = 32243;
Expected Output: 34223

Pictorial Presentation:

JavaScript: Reverse a number

Sample Solution: -

HTML Code:

<!DOCTYPE html>
<meta charset=utf-8 />
<title>Reverse a number</title>

JavaScript Code:

function reverse_a_number(n)
	n = n + "";
	return n.split("").reverse().join("");

Sample Output:


Assume n = 1000.
Convert a number to a string :
Code : -> n = n + "";
Note : There are different ways to convert number to string :

  • String literal -> str = "" + num + "";
  • String constructor -> str = String(num);
  • toString -> str = num.toString();
  • String Literal simple -> str = "" + num;

The split() method is used to split a String object into an array of strings by separating the string into substrings.
Code : console.log('1000'.split(""));
Output : ["1", "0", "0", "0"]

The reverse() method is used to reverse an array in place. The first array element becomes the last and the last becomes the first.
Code : console.log(["1", "0", "0", "0"].reverse());
Output : ["0", "0", "0", "1"]

The join() method is used to join all elements of an array into a string.
Code : console.log(["1", "0", "0", "0"].reverse().join(""));
Output : "0001"


Flowchart: JavaScript function: Reverse a number

Live Demo:

See the Pen JavaScript -Reverse a number-function-ex- 1 by w3resource (@w3resource) on CodePen.

Improve this sample solution and post your code through Disqus

Previous: Write a JavaScript program to find the smallest prime number strictly greater than a given number.
Next: Write a JavaScript function that checks whether a passed string is palindrome or not?

What is the difficulty level of this exercise?

JavaScript: Tips of the Day

JavaScript: Shorten your "if" statements

Now this is a tricky one.
Shortening your0 "if" statements can be a great way to simplify your code.
However, if you need to write more complicated statements, you should definitely go for the first option.

// Instead of using this                                      
if (iAmHungry) {
// You can use this
if (iAmHungry) bakeAnEgg()
// Or this
iAmHungry? bakeAnEgg() : 0

Remember, readability & ease-of-use are more important than a couple less lines of code.

Ref: https://bit.ly/2LBj213